I received an error stating "Windows Installation is Outdated".

The NumXL installer checks for the existing windows and excel installation and compares it against NumXL minimum compatibility requirements. This is done to ensure a seamless operation of our add-in with Microsoft Excel.

Currently, the older Microsoft Windows 7/8 and 8.1 installations cause a compatibility issue with NumXL when the required windows update - KB2999226 - is missing or broken on your computer. It is required  to apply this windows update (KB2999226) before you can install NumXL.

Where can I download KB2999226 from?

To acquire the required Microsoft Windows update, you have two options:

  • (Recommended) Using Windows updates app in your computer's control pannel, install the latest Windows updates for your system. It is not necessary for you to install any optional update(s).
  • In the event that the windows updates app is not working properly, you can try to download this particular update from the Microsoft support site, and install it on your computer.
Have more questions? Submit a request

2 Comments

  • 0
    Avatar
    Support Team

    If I try to manually install KB2999226, I get this error, "This update is not applicable for your computer".

    Edited by Mohamad
  • 0
    Avatar
    Support Team

    Some updates require a prerequisite update before they can be applied to a system. If you are missing a prerequisite update, you may encounter this error message.

     

    To install this update, you must have April 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 (2919355) installed in Windows 8.1 or Windows Server 2012 R2. Or, install Service Pack 1 for Windows 7 or Windows Server 2008 R2. Or, install Service Pack 2 for Windows Vista and for Windows Server 2008.

    Edited by Mohamad