The "Run X-12" button in X12-ARIMA wizard remains disabled


I have been running X12-ARIMA in NumXL every day for months on the same series (with a few new added values every day) with no problem. Today, however, no seasonal adjustments are working at all! All series are broken, I have attached one for illustration. Please help in solving this urgently as I rely on using it daily in my work.

I am not aware of any updates, changed settings or otherwise on my computer and it worked fine yesterday. Whenever I go through the wizard I can only do "apply" but the Run X12-A does not light up. So of course the formula does not work when called by X12acomp etc.

I tried rebooting, removing the add-ins, uninstalling it, installing the latest version, and activating the add-in again in excel.


  • The X12-ARIMA functionality in NumXL relies on large set of script files, and occasionally one of those scripts invokes commands on the user's machine (part of windows installation). Your machine has undergone a change due to automatic windows update program or by an IT personnel.

     Going forward, we have identified the root cause and a fix is underway to be released to general public to avoid this error from re-occurring. 

    Comment actions Permalink
  • The fix for this issue is now part of 1.61.41535.1 (Update 8).

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post